Labs: IOS配置基本域间 (Inter-AS) MPLS/VPN服务

一个大型的企业网络(customer A)已经在两个服务提供商(SP Left和SP Right)中铺设了连接他们的VPN站点的MPLS VPN服务,见下图:
basic-inter-as-mpls-vpn-service
虽然客户能够通过在不同的服务提供商之间的一条站点间专线(Inter-Site)建立VPN站点间的连接,但是客户希望能够通过一条运营商之间的链路把两个独立的VPN连接起来,从而避免站点间的流量在站点内部传输。

本练习中,你将使用一个优化客户A所有站点之间连接性能的域间MPLS VPN的设计来连接两个MPLS/VPN骨干;同时你需要在服务提供商之间相互映射路由目标和路由区分符,使用一个不相兼容的地址架构。

作为过渡到铺设成熟的域间服务的临时过渡方案,你需要先建立一条VRF链路来连接两个MPLS/VPN骨干网;每个骨干将被另外一个骨干看作一个巨大的客户站点,见下图。由于ASBR-L和ASBR-R之间只有一条物理链路,你需要把这条VRF链路配置在连接AS边界路由器之间的隧道接口上。
basic-inter-as-mpls-vpn-service
临时过渡方案铺设完毕,并且所有的客户站点已经能够成功连接以后,你需要铺设最终的域间MPLS/VPN解决方案,在AS边界路由器之间通过多协议EBGP交换VPN路由,见下图:
basic-inter-as-mpls-vpn-service

实验演示: IOS配置基本域间 (Inter-AS) MPLS/VPN服务 – 完整版

点击上文↑链接收看高清版本实验视频

youtube labs

实验视频分段演示点播

以下是实验过程中可能使用到的命令:

  • address-family ipv4 vrf-name
    选择在路由协议内为每个VRF进程配置
  • address-family vpnv4
    在BGP路由进程选择VPNv4地址族配置
  • clear ip bgp *|ip-address
    重置BGP会话
  • clear ip bgp *|ip-address soft in
    请求从BGP邻居重新获得BGP路由更新
  • interface Tunnel x
    创建一个隧道接口
  • tunnel destination ip-address
    指定隧道接口所使用的传输目标的IP地址
  • tunnel source ip-address
    指定隧道接口所使用的传输源的IP地址
  • ip vrf forwarding vrf-name
    把一个接口绑定到某个VRF上面
  • ip vrf vrf-name
    创建一个虚拟路由/转发表(VRF)
  • ping vrf-name host
    通过查询某个VRF检验主机的可达性
  • rd value
    为VRF分配路由区分符(RD)
  • address-family ipv4 vrf-name
    选择在路由协议内为每个VRF进程配置
  • address-family vpnv4
    选择VPNv4地址族配置
  • ip vrf forwarding vrf-name
    把一个接口绑定到某个VRF上面
  • ip vrf vrf-name
    创建一个虚拟路由/转发表(VRF)
  • neighbor ip-address remote-as as-number
    配置一个BGP邻居
  • no auto-summary
    关闭在网络边缘的子网自动汇总
  • neighbor ip-address activate
    为指定的邻居激活在地址族下交换路由
  • neighbor ip-address routere-flector-client
    在路由反射器上配置一个路由反射器客户
  • neighbor ip-address next-hop-self
    对于指定的邻居修改BGP下一跳属性
  • no bgp default route-target filter
    关闭缺省的对于VPNv4路由的基于路由目标的过滤
  • ping vrf-name host
    通过查询某个VRF检验主机的可达性
  • route-map name permit seq
    创建一个route-map的条目
  • router bgp as-number
    选择BGP配置
  • route-target import|export value
    给一个VRF分配一个路由目标(Route Target)
  • show ip bgp vpnv4 vrf-name
    显示某个指定邻居的VPNv4路由
  • show ip route vrf-name
    显示某个特定VRF的IP路由表
  • show ip vrf detail
    显示VRF的详细内容
  • telnet host /vrf-name
    Telnet到与特定VRF直连的CE路由器上
  • show ip bgp [ vpnv4 vrf-name ] prefix
    显示某个特定VRF的VPNv4路由
Advertisements

Labs: IOS MPLS/VPN 互联网接入配置之路由泄露

ios-mpls-internet-connectivity-through-route-leaking

实验演示: IOS MPLS/VPN 互联网接入配置之路由泄露 – 完整版

点击上文↑链接收看高清版本实验视频

youtube labs

实验视频分段演示点播

Labs: IOS配置MPLS/VPN PE和CE之间运行BGP

本实验将在MPLS/VPN的PE和CE路由器之间配置BGP路由协议mpls-running-bgp-between-the-pe-and-ce-routers

客户希望把中心站点(A1和A3)从RIP合并到BGP上,而末节站点(A3和A4)则注入RIP缺省路由,见下图:
mpls-running-bgp-between-the-pe-and-ce-routers2

实验演示: IOS配置MPLS/VPN PE和CE之间运行BGP – 完整版

点击上文↑链接收看高清版本实验视频

youtube labs

实验视频分段演示点播

本实验练习中,你将合并PE路由器和CE路由器(A1、A2)的路由协议,由RIP到BGP,你需要完成以下工作——

  1. 配置BGP作为PE路由器和CE路由器之间的路由协议;
  2. 使用AS-override特征集在客户的站点间使用相同的AS号码交换路由
  3. 在A2上使用Local Preference和MED,选择主要链路和备份链路
  4. 通过在PE路由器上通告缺省路由优化RIP路由
  5. 检验当主链路失效以后备份链路对其替换;以及当主链路恢复以后自动成为活跃链路
  6. 调谐BGP时间参数优化BGP收敛

以下是实验过程中可能使用到的命令:

  • address-family ipv4 vrf-name
    选择在路由协议内为每个VRF进程配置
  • address-family vpnv4
    选择VPNv4地址族配置
  • clear ip bgp *|ip-address
    重置BGP会话
  • clear ip bgp *|ip-address soft in
    请求从BGP邻居重新获得BGP路由更新
  • default-information originate
    在特定的路由进程内向邻居通告一条缺省路由
  • ip vrf forwarding vrf-name
    把一个接口绑定到某个VRF上面
  • ip vrf-name
    创建一个虚拟路由/转发表(VRF)
  • ping vrf-name host
    通过查询某个VRF检验主机的可达性
  • rd value
    为VRF分配路由区分符(RD)
  • address-family ipv4 vrf-name
    选择在路由协议内为每个VRF进程配置
  • address-family vpnv4
    选择VPNv4地址族配置
  • neighbor ip-address remote-as as-number
    配置一个BGP邻居
  • neighbor ip-address route-map name in|out
    对于向指定的邻居接收或者发送的BGP路由更新应用一个route-map
  • no auto-summary
    关闭在网络边缘的子网自动汇总
  • no router rip
    关闭RIP路由进程
  • neighbor ip-address activate
    为指定的邻居激活在地址族下交换路由
  • neighbor ip-address routere-flector-client
    在路由反射器上配置一个路由反射器客户
  • ping vrf-name name host
    通过查询某个VRF检验主机的可达性
  • route-map name permit seq
    创建一个route-map的条目
  • router bgp as-number
    选择BGP配置
  • route-target import|export value
    给一个VRF分配一个路由目标(Route Target)
  • show ip bgp vpnv4 vrf-name
    显示某个指定邻居的VPNv4路由
  • show ip route vrf-name
    显示某个特定VRF的IP路由表
  • show ip vrf detail
    显示VRF的详细内容
  • telnet host /vrf-name
    Telnet到与特定VRF直连的CE路由器上
  • set local value
    在ROUTE-MAP中设置BGP本地优先属性
  • set metric value
    在ROUTE-MAP中设置BGP MED属性
  • show ip bgp [ vpnv4 vrf-name ] prefix
    显示某个特定VRF的VPNv4路由

Labs: IOS配置MPLS/VPN PE和CE之间运行OSPF

本实验将在MPLS/VPN的PE和CE路由器之间配置OSPF路由协议

有的客户使用OSPF作为路由协议在他们的VPN内运行,有时候在某些站点甚至结合RIP和BGP同时使用。本实验中,你将铺设OSPF作为在客户的VPN内部运行的路由协议。你需要完成以下的工作以达到这个目标:把OSPF作为PE和CE路由器之间的路由协议激活;在客户站点之间传输OSPF路由;配置到额外的运行RIP路由协议的客户路由器的连通。在铺设OSPF的过程中,你将面对几个问题:结合OSPF和其他路由协议共同工作(例如,RIP);重叠的OSPF区域号码;注入PE路由器以后而造成的不连续的OSPF骨干区域(Area 0)。
mpls-running-ospf-between-pe-and-ce-routers

背景信息

原来的客户网络包括OSPF area0(骨干区域)和OSPF area3,同时有附加的不运行OSPF而运行RIP路由协议的路由器;RIP路由通过重分布进入OSPF,见下图:
mpls-running-ospf-between-pe-and-ce-routers2
随着客户从原来的帧中继网络向MPLS/VPN网络过渡,服务提供商把PE和CE之间的路由协议改为RIP,见下图:
mpls-running-ospf-between-pe-and-ce-routers3
鉴于RIP作为路由协议的局限性,客户希望重新改为使用OSPF所谓路由协议。然而,由于MPLS/VPN在CE路由器之间加入了PE路由器,骨干区域和area3不在是一个连续的区域,这正是其中一个我们需要解决的问题,见下图:
mpls-running-ospf-between-pe-and-ce-routers4

实验演示: IOS配置MPLS/VPN PE和CE之间运行OSPF – 完整版

点击上文↑链接收看高清版本实验视频

youtube labs

实验视频分段演示点播

以下是实验过程中可能使用到的命令:

  • address-family ipv4 vrf-name
    选择在路由协议内为每个VRF进程配置
  • address-family vpnv4
    选择VPNv4地址族配置
  • ip vrf forwarding vrf-name
    把一个接口绑定到某个VRF上面
  • ip vrf-name
    创建一个虚拟路由/转发表(VRF)
  • ping vrf-name host
    通过查询某个VRF检验主机的可达性
  • rd value
    为VRF分配路由区分符(RD)
  • address-family ipv4 vrf-name
    选择在路由协议内为每个VRF进程配置
  • address-family vpnv4
    选择VPNv4地址族配置
  • neighbor ip-address activate
    为指定的邻居激活在地址族下交换路由
  • neighbor ip-address routere-flector-client
    在路由反射器上配置一个路由反射器客户
  • ping vrf-name host
    通过查询某个VRF检验主机的可达性
  • redistribute bgp as-number subnets
    重分布BGP路由;包括子网路由,到OSPF内
  • router ospf process vrf-name
    在制定的VRF内启动OSPF
  • router bgp as-number
    选择BGP配置
  • route-target import|export value
    给一个VRF分配一个路由目标(Route Target)
  • show ip ospf database
    显示OSPF数据库
  • show ip bgp vpnv4 vrf-name
    显示某个指定邻居的VPNv4路由
  • show ip route vrf-name
    显示某个特定VRF的IP路由表
  • show ip vrf detail
    显示VRF的详细内容
  • telnet host /vrf-name
    Telnet到与特定VRF直连的CE路由器上

Labs: IOS帧模式MPLS配置

本实验涵盖了在核心骨干网配置帧模式的MPLS架构

ios-frame-mode-mpls-configuration

实验演示: IOS帧模式MPLS配置 – 完整版

点击上文↑链接收看高清版本实验视频

youtube labs

实验视频分段演示点播

本实验练习过程中,你将进行——

  1. 初始化MPLS配置,MPLS通常为了在网络骨干实现MPLS/VPN或者赋予由MPLS技术所带来的增值服务而在服务提供商的骨干网络铺设;这些增值服务通常包括基于MPLS的流量工程(TE);易于MPLS的服务质量;在骨干路由器上关闭BGP路由。练习中,你将在ISP骨干网络中配置简单的标签交换功能,并且关闭那些没有直连客户路由器的核心路由器上的BGP路由功能。
  2. 关闭TTL传播,你将关闭MPLS标签在IP TTL中转播,从而对客户把你的骨干网络隐藏起来。
  3. 配置有条件标签通告,通过使用TDP的有条件标签通告特性去为除了你的核心的广域网接口子网以外的其他地址配置标签交换。

以下是实验过程中可能使用到的命令:

  • ip cef
    配置CEF交换
  • tag-switching ip
    在接口上运行MPLS
  • no router bgp –
    在核心路由器上关闭BGP路由功能
  • no neighbor ip-address
    去除原有的BGP邻居
  • show tag-switching tdp neighbors
    检验TDP邻居是否工作正常
  • show tag-switching tdp bindings
    检验标签在邻居之间正常分配和分发
  • no tag-switching ip propagate-ttl
    关闭TTL传播IP包头和MPLS标签头之间的映射
  • access-list
    指定访问控制列表去定义相应的IP前缀,这些IP前缀标签将被通告
  • tag-switching advertise access-list
    为指定的访问控制列表中定义的IP前缀作有条件的标签通告
  • show tag-switching tdp bindings
    检验邻居间的标签分配和分发

Labs: IOS MPLS/VPN初始化配置

本实验中你将为你的客户创建一个简单的MPLS/VPN

ios-initial-mpls-vpn-setup

RIP路由优化

optimize-rip-routing

实验演示: IOS MPLS/VPN初始化配置 – 完整版

点击上文↑链接收看高清版本实验视频

youtube labs

实验视频分段演示点播

本实验练习过程中,你将进行——

  1. 在你的骨干网内铺设MPLS VPN架构。
  2. 把你的客户从全局路由合并到简单的VPN中。
  3. 把PE和CE路由器之间的路由更新改变为通过RIP路由协议交换,同时该项练习也包括了一个可选性的实验,让那些学有余力的学员去优化PE和CE路由器之间的RIP路由更新。

以下是实验过程中可能使用到的命令:

  • address-family ipv4 vrf-name
    选择在路由协议内为每个VRF进程配置
  • address-family vpnv4
    选择VPNv4地址族配置
  • ip vrf forwarding vrf-name
    把一个接口绑定到某个VRF上面
  • ip vrf-name
    创建一个虚拟路由/转发表(VRF)
  • neighbor ip-address activate
    为指定的邻居激活在地址族下交换路由
  • neighbor ip-address routere-flector-client
    在路由反射器上配置一个路由反射器客户
  • ping vrf-name host
    通过查询某个VRF检验主机的可达性
  • rd value
    为VRF分配路由区分符(RD)
  • redistribute bgp as-number metric transparent
    把BGP的路由重分布到RIP里面去,将BGP的MED值作为RIP的跳数;形成RIP路由METRIC
  • redistribute rip
    把RIP路由重分布到BGP
  • redistribute static
    把静态路由重分布到动态路由协议
  • router bgp as-number
    选择BGP配置
  • route-target import|export value
    给一个VRF分配一个路由目标(Route Target)
  • show ip bgp neighbor
    显示全局BGP邻居信息
  • show ip bgp vpnv4 vrf-name
    显示某个指定邻居的VPNv4路由
  • show ip route vrf-name
    显示某个特定VRF的IP路由表
  • show ip vrf detail
    显示VRF的详细内容
  • telnet host /vrf-name
    Telnet到与特定VRF直连的CE路由器上