JNCIP实验视频: JUNOS OSPF路由汇总及LSA管理02

junos-ospf-address-summary-and-inter-area-lsa-filtering-2
youtube

JNCIP实验: OSPF地址汇总及域间LSA管理 Part02/03

点击上文↑链接至YouTube收看高清版本实验视频

手动汇总Juniper路由器OSPF域间LSA-3

为了显示地址汇总的效果,我们先保存一下没有进行汇总前区域0的OSPF数据库快照:

nigel@junos# run show ospf database logical-router r5
area 0 

    OSPF link state database, Area 0.0.0.0
 Type       ID       Adv Rtr   Seq     Age Opt Cksum Len
Router   10.0.3.3  10.0.3.3 0x80000043 16 0x22 0xf964 60
Router   10.0.3.4  10.0.3.4 0x8000005b 16 0x22 0xb27  60
Router  *10.0.3.5  10.0.3.5 0x80000043 15 0x22 0x1f34 60
Network  10.0.2.2  10.0.3.3 0x8000000a 48 0x22 0xa84b 32
Network  10.0.2.6  10.0.3.4 0x8000004c 03 0x22 0xe3c9 32
Network  10.0.2.10 10.0.3.4 0x8000000a 10 0x22 0x5c8d 32
Summary *6.0.0.0   10.0.3.5 0x80000008 15 0x22 0xb368 28
Summary *6.0.1.0   10.0.3.5 0x80000008 15 0x22 0xa872 28
Summary *6.0.2.0   10.0.3.5 0x80000008 15 0x22 0x9d7c 28
Summary *6.0.3.0   10.0.3.5 0x80000008 15 0x22 0x9286 28
Summary  10.0.4.4  10.0.3.3 0x8000003d 16 0x22 0xc41a 28
Summary  10.0.4.4  10.0.3.4 0x80000054 16 0x22 0x8641 28
Summary  10.0.4.8  10.0.3.3 0x8000003d 16 0x22 0xa633 28
Summary  10.0.4.8  10.0.3.4 0x80000054 16 0x22 0x5470 28
Summary  10.0.4.12 10.0.3.3 0x8000003e 16 0x22 0x686e 28
Summary  10.0.4.12 10.0.3.4 0x80000054 16 0x22 0x407e 28
Summary  10.0.6.1  10.0.3.3 0x8000003c 16 0x22 0xd608 28
Summary  10.0.6.1  10.0.3.4 0x80000053 16 0x22 0xa224 28
Summary  10.0.6.2  10.0.3.3 0x8000003b 16 0x22 0xd805 28
Summary  10.0.6.2  10.0.3.4 0x80000053 16 0x22 0x8e38 28
Summary *10.0.8.0  10.0.3.5 0x8000003d 15 0x22 0xaa33 28
Summary *10.0.8.4  10.0.3.5 0x80000001 15 0x22 0xf026 28
Summary *10.0.8.8  10.0.3.5 0x80000001 15 0x22 0xc84a 28
Summary *10.0.9.6  10.0.3.5 0x80000001 15 0x22 0xe32d 28
Summary *10.0.9.7  10.0.3.5 0x80000001 15 0x22 0xd936 28
ASBRSum  10.0.6.1  10.0.3.3 0x8000003b 16 0x22 0xca14 28
ASBRSum  10.0.6.1  10.0.3.4 0x80000053 16 0x22 0x9431 28
ASBRSum *10.0.9.7  10.0.3.5 0x8000003c 15 0x22 0x557e 28

    OSPF AS SCOPE link state database
 Type       ID       Adv Rtr   Seq     Age Opt Cksum Len
Extern 3.0.0.0     10.0.3.4 0x80000055 16 0x22 0x555a 36
Extern 200.200.0.0 10.0.9.7 0x8000006a 28 0x22 0xcece 36

无论是普通区域还是NSSA,域间LSA-3汇总都在[edit protocols ospf area]层次下配置,汇总普通区域0.0.0.1到骨干区域的LSA-3:

[edit logical-routers r5]
nigel@junos# set protocols ospf area 1 area-range
10.0.8/23 

[edit logical-routers r5]
nigel@junos# show protocols ospf area 1
area-range 10.0.8.0/23;
interface fxp1.56;
interface fxp1.57;

重新查看R3的路由表,原有的5段路由全部被汇总到10.0.8/23里面,默认情况下:汇总后路由的Metric取值是明细路由当中Metric值最大的路由之Metric,可以通过override-Metric参数进行手动修改。

nigel@junos# run show route protocol ospf logical-router
r3 10.0.8/23 

inet.0: 24 destinations, 24 routes (24 active,
0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

10.0.8.0/23        *[OSPF/10] 00:00:21, metric 3
                    > to 10.0.2.1 via fxp1.35

继续汇总NSSA 0.0.0.10到骨干区域的LSA-3,需要注意的是区域10与骨干区域之间同时存在R3/R4两个ABR,因此我们需要同时在R3/R4两台路由器上进行汇总:

[edit logical-routers]
nigel@junos# set r3 protocols ospf area 10 area-range
10.0.4.0/22 

[edit logical-routers]
nigel@junos# set r4 protocols ospf area 10 area-range
10.0.4.0/22 

nigel@junos# show r3 protocols ospf
area 0.0.0.10 {
    nssa {
        default-lsa {
            default-metric 10;
            type-7;
        }
        no-summaries;
    }
    area-range 10.0.4.0/22;
    interface fxp2.13 {
        metric 2;
    }
}

我们在这里只列出了R3上的层次配置,相类似的配置同样应该在R4上应用,最后查看R5路由表,确认另外5段路由全部被汇总被汇总进来:

nigel@junos# run show route logical-router
r5 10.0.4.0/22 

inet.0: 23 destinations, 23 routes (23 active,
0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

10.0.4.0/22        *[OSPF/10] 00:00:05, metric 4
                    > to 10.0.2.10 via fxp2.45

手动过滤Juniper路由器OSPF域间LSA-3

除了汇总以外,过滤不必要的LSA也能有效的压缩OSPF LSDB的体积,与地址汇总相同,无论是普通区域还是NSSA,域间LSA-3汇总都在[edit protocols ospf area]层次下配置,在area-range命令后加上restrict参数。根据题目需求,我们需要将6.0.0/24-6.0.3/24这4段路由进行过滤,我们实际上采用的是“先汇总,后过滤”的形式:

nigel@junos# run show route logical-router r3 6/22    

inet.0: 24 destinations, 24 routes (24 active,
0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

6.0.0.0/24         *[OSPF/10] 03:45:58, metric 2
                    > to 10.0.8.5 via fxp1.56
6.0.1.0/24         *[OSPF/10] 03:45:58, metric 2
                    > to 10.0.8.5 via fxp1.56
6.0.2.0/24         *[OSPF/10] 03:45:58, metric 2
                    > to 10.0.8.5 via fxp1.56
6.0.3.0/24         *[OSPF/10] 03:45:58, metric 2
                    > to 10.0.8.5 via fxp1.56

[edit logical-routers]
nigel@junos# set r5 protocols ospf area 1 area-range
6/22 restrict 

[edit logical-routers]
nigel@junos# show r5 protocols ospf area 1
area-range 10.0.8.0/23;
area-range 6.0.0.0/22 restrict;
interface fxp1.56;
interface fxp1.57;

重新查看R3路由表,6/22网段从路由表内消失:

nigel@junos# run show route logical-router r3 6/22             

[edit logical-routers]
nigel@junos#
Advertisements

JNCIP实验视频: JUNOS OSPF路由汇总及LSA管理01

junos-ospf-address-summary-and-inter-area-lsa-filtering
youtube

JNCIP实验: OSPF地址汇总及域间LSA管理 Part01/03

点击上文↑链接至YouTube收看高清版本实验视频

实验目标:

  1. 在R6上,以域内路由形式通告6.0.0.0/24-6.0.3.0/24网段;这些LSA只允许在区域0.0.0.1内通告,而不允许以LSA-3的形式出现在其他区域;
  2. 除上述网段以外,区域0.0.0.10和区域0.0.0.1内的全部域内路由,均应该经过汇总后进入骨干区域;
  3. 阻止3/8 NSSA LSA离开区域0.0.0.10;

关键点评

  1. 使用JUNOS路由表确认地址汇总掩码;
  2. 手动汇总OSPF域间LSA-3;
  3. 手动过滤OSPF域间LSA-3;
  4. 手动过滤OSPF NSSA LSA-7;

作为链路状态路由协议,OSPF邻居之间交换的仅仅是链路状态信息(LSA),根据不同的LSA我们将它们进行分类。然而OSPF邻居之间并不会直接交换路由信息,路由意味着最佳路径,而链路状态路由协议与距离矢量路由协议最大的区别便在于邻居之间是否交换路由,是否允许邻居替本地路由器选择最佳路径?距离矢量路由协议,如RIP,邻居之间交换的是路由信息,因为上游邻居只会将它认为的最佳路径转发给下游邻居。而OSPF则不同,无论邻居选择的最佳路径是什么,它都必须将这个LSDB向它的邻居通告,由本地路由器自己进行SPF计算。我们之所以在手册或者演示视频当中提及“OSPF路由”,只是为了表述简洁方便而已。

正因为需要遵循RFC所定义的链路状态路由协议原则,同一个区域内所有路由器关于该区域的数据库绝对是同步的:作为OSPF邻居,并没有权利限制其他路由器的知情权力。因此不会存在所谓域内OSPF LSA过滤这一说法。在JUNOS的OSPF当中域内LSA同样不能被过滤或者汇总修改。然而,为了减轻整个OSPF AS内的LSA数量,正如在之前的演示当中,我们可以通过设置不同类型的区域来在域间对各种类型的LSA进行过滤。现在我们要做的是另外一种更细化的优化OSPF数据库的体积的方式,通过域间汇总/LSA管理过滤来达到以上目的。

在R6上加入6.0.x-3/24 OSPF域内路由

我们通过在R6上创建一个配置了多个IP地址的逻辑接口,并且把该接口在OSPF区域1里面通告:

fxp1 {
    unit 68 {
        vlan-id 68;
        family inet {
            address 6.0.0.1/24;
            address 6.0.1.1/24;
            address 6.0.2.1/24;
            address 6.0.3.1/24;
        }
    }
}

nigel@junos# set protocols ospf area 1 interface fxp1.68
passive  

通过查看R5的OSPF数据库,可以发现新增的4个网段已经包含在R6的LSA-1中被通告出来:

nigel@junos# run show ospf database logical-router r5
lsa-id 10.0.9.6 area 1 extensive 

    OSPF link state database, Area 0.0.0.1
 Type     ID       Adv Rtr   Seq   Age Opt  Cksum  Len
Router 10.0.9.6 10.0.9.6 0x80000037 26 0x22 0x8654 108
  bits 0x0, link count 7
  id 6.0.3.0, data 255.255.255.0, Type Stub (3)
  TOS count 0, TOS 0 metric 1
  id 6.0.2.0, data 255.255.255.0, Type Stub (3)
  TOS count 0, TOS 0 metric 1
  id 6.0.1.0, data 255.255.255.0, Type Stub (3)
  TOS count 0, TOS 0 metric 1
  id 6.0.0.0, data 255.255.255.0, Type Stub (3)
  TOS count 0, TOS 0 metric 1
  id 10.0.8.5, data 10.0.8.5, Type Transit (2)
  TOS count 0, TOS 0 metric 1
  id 10.0.8.1, data 10.0.8.1, Type Transit (2)
  TOS count 0, TOS 0 metric 1
  id 10.0.9.6, data 255.255.255.255, Type Stub (3)
  TOS count 0, TOS 0 metric 0
  Aging timer 00:59:33
  Installed 00:00:25 ago, expires in 00:59:34,
  sent 00:00:25 ago
  Last changed 00:00:25 ago, Change count: 6

使用JUNOS路由表确认地址汇总掩码

OSPF域间LSA管理,主要包括地址汇总以及LSA域间过滤两个部分,我们先从地址汇总开始。在JNCIx考试中,当要求对OSPF域内路由进行汇总注入骨干区域的时候,注意除了路由器之间的直连网段还不要忘记把路由器的环回接口网段一并汇总到同一条路由当中。另外,汇总后的网络往往或多或少的覆盖了除现有明细网段以外的其他网段,不需要太担心IP地址重叠的问题,在设计编址的时候已经将汇总的需求一并考虑在内了,这些被覆盖的网段也不会出现在实验当中。过去,在IOS上面往往通过汇总后数路由来确认当前汇总的掩码是否最佳选择,或者有没有被漏掉的子网没有被汇总进来。这样子做不是不好,只是可能需要多调节几次配置以得到最佳配置。而因为JUNOS的路由表查看方式是当我们输入一个网段以后,将返回给我们所有属于该网段底下的子网路由,这个特性能够自动为我们在应用汇总配置之前检查汇总掩码是否最为合适。以区域1为例,由于实验需求禁止6.0.0.0/24-6.0.3.0/24网段进入骨干区域,我们需要确认将R5/R6/R7的三段直连网段路由,以及R6/R7的环回接口网段共5段路由被汇总进来。不妨选择查看R3的OSPF路由表:

nigel@junos# run show route protocol ospf logical-router 
r3 10.0.8/22 

inet.0: 28 destinations, 28 routes (28 active, 
0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

10.0.8.0/30        *[OSPF/10] 02:38:31, metric 3
                    > to 10.0.2.1 via fxp1.35
10.0.8.4/30        *[OSPF/10] 02:38:31, metric 2
                    > to 10.0.2.1 via fxp1.35
10.0.8.8/30        *[OSPF/10] 02:38:31, metric 2
                    > to 10.0.2.1 via fxp1.35
10.0.9.6/32        *[OSPF/10] 02:38:31, metric 2
                    > to 10.0.2.1 via fxp1.35
10.0.9.7/32        *[OSPF/10] 02:37:46, metric 2
                    > to 10.0.2.1 via fxp1.35

先使用/22位掩码,发现5段路由被全部汇总进来,接着使用/24位掩码发出第二次查询:

nigel@itaalab# run show route protocol ospf logical-router 
r3 10.0.8/24    

inet.0: 28 destinations, 28 routes (28 active, 
0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

10.0.8.0/30        *[OSPF/10] 02:38:33, metric 3
                    > to 10.0.2.1 via fxp1.35
10.0.8.4/30        *[OSPF/10] 02:38:33, metric 2
                    > to 10.0.2.1 via fxp1.35
10.0.8.8/30        *[OSPF/10] 02:38:33, metric 2
                    > to 10.0.2.1 via fxp1.35

结果发现/24位掩码只汇总了三段路由,缺少了R6/R7两台路由器的环回接口网段路由,于是发出第三次查询,得出结果/23为掩码为最佳掩码,可以开始汇总配置:

nigel@junos# run show route protocol ospf logical-router 
r3 10.0.8/23    

inet.0: 28 destinations, 28 routes (28 active, 
0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

10.0.8.0/30        *[OSPF/10] 02:38:35, metric 3
                    > to 10.0.2.1 via fxp1.35
10.0.8.4/30        *[OSPF/10] 02:38:35, metric 2
                    > to 10.0.2.1 via fxp1.35
10.0.8.8/30        *[OSPF/10] 02:38:35, metric 2
                    > to 10.0.2.1 via fxp1.35
10.0.9.6/32        *[OSPF/10] 02:38:35, metric 2
                    > to 10.0.2.1 via fxp1.35
10.0.9.7/32        *[OSPF/10] 02:37:50, metric 2
                    > to 10.0.2.1 via fxp1.35

JNCIP实验视频: OSPF NSSA配置及Metric Mania

jncip-labs-ospf-nssa-metirc-mania
本实验相关参考文档:

JNCIP实验: OSPF NSSA区域配置及Metric Mania Part01/05

点击上文↑链接至YouTube收看高清版本实验视频

JNCIP实验: OSPF NSSA区域配置及Metric Mania Part02/05

点击上文↑链接至YouTube收看高清版本实验视频

JNCIP实验: OSPF NSSA区域配置及Metric Mania Part03/05

点击上文↑链接至YouTube收看高清版本实验视频

JNCIP实验: OSPF NSSA区域配置及Metric Mania Part04/05

点击上文↑链接至YouTube收看高清版本实验视频

JNCIP实验: OSPF NSSA区域配置及Metric Mania Part05/05

点击上文↑链接至YouTube收看高清版本实验视频

JNCIP实验视频: OSPF末节区域(Stub)/TSA配置

jncip-labs-ospf-stub-area-and-totally-stub-area-configuration
我们继续JNCIP系列的JUNOS OSPF实验视频演示。在发布新的实验文档以前,我先回过头来补充之前几个OSPF分解实验的演示视频。

本实验相关参考文档:

JNCIP实验: OSPF末节区域(Stub)/TSA配置 Part01/02

点击上文↑链接至YouTube收看高清版本实验视频

JNCIP实验: OSPF末节区域(Stub)/TSA配置 Part02/02

点击上文↑链接至YouTube收看高清版本实验视频

JUNOS软件内核(kernel)及路由协议进程(rpd)架构

junos-software-architecture
Jeff Doyle之前已经介绍过JUNOS内核来自一份被Juniper工程师经过高度个性化修改 — 包括卸载不必要的组件与驱动程序,以及根据JUNOS的开发需求重写某些系统代码等等的FreeBSD系统内核(kernel)。尽管如此,我们依然能够在JUNOS内部随处发现FreeBSD的痕迹。譬如,在配置Juniper路由器接口IP地址的时候,我们所使用的“family inet”实际上引用的便是BSD套接字(Socket)编程中的“AF_INET”通信协议族。注意,除了FreeBSD以外,包括我正在用的Mac OS X在内,还有许多基于BSD架构的UNIX系统,如OpenBSDNetBSD等等。

junos-software-modular-architecture回到JUNOS上面,而JUNOS系统软件内部的模块化独立设计,则是Juinper路由器相对其他厂商的网络设备能够更为稳定可靠运作的关键因素。JUNOS系统软件内的各个软件模块又可以被称作系统进程,包括路由器网络管理进程,路由协议进程,接口进程,命令行,采样进程,CoS以及机箱硬件管理进程均运行在JUNOS内核之上(如图中所示)。而JUNOS内核则负责对上层进程执行统一资源分配与管理协调,从而保障各个进程被独立分配在“hardware-assisted”隔离的内存空间内运行。因此,单一软件进程的失效并不会造成系统的全面瘫痪。另外,我们也可以轻易的在其他软件进程正常工作的同时重启某个JUNOS软件进程,而无需让系统全面重启或是担心对该进程的管理而造成对其它系统软件进程的影响。例如,我们可以在CLI下面独立的重启JUNOS路由协议守护进程(rpd)。

nigel@junos> restart routing
Routing protocol daemon started, pid 751

同时,Juniper路由器路由引擎(RE)与包转发引擎(PFE)相互分离的设计架构体系,保证流经路由器的数据包仅经过PFE转发。因此,在重启RE上的JUNOS路由协议软件进程的过程中,并不会造成网络传输中断或数据包丢失。JUNOS系统软件被安装在基于Intel PCI平台的路由引擎(RE)上面,通过路由协议守护进程(routing protocol daemon)管理路由器上运行的各种路由协议并维护路由表(Routing Information Base)。路由引擎(RE)通过RIB内的目的IP网段信息建立一份本地的转发信息表(Master FIB),再通过100Mbps的背板链路fxp1,对包转发引擎(PFE)上在真正执行数据转发时所使用的转发信息表FIB(Forwarding Table)进行增量更新。所以,即便在存有大量路由更新及抖动的情况下,依然能够保证Juniper路由器达到线速转发性能。同时,JUNOS内核除了负责连接RE与PFE以及它们之间的通讯以外,同时负责RE上的主FIB表与PFE上FIB表之间的同步。

Aggregate/Generate动态默认路由反传统接入设计

cisco-ios-internet-access-by-juniper-junos-aggregate-generate-dynamic-default-route
我在今天的实验演示中除了包含一种新型的通过与客户端路由器进行动态路由互动的设计方案以外,另外在实验的过程中我同时也演示了JUNOS Aggregate routeGenerate route之间的区别。我曾经在之前的JUNOS Aggregate routes pk. Generate routes中提及到,今天一并通过实验演示进一步进行验证。

在传统的企业/园区网甚至某些城域网末节结点上,接入ISP或骨干网的设计方案为简单的在客户端路由器上指定一条默认路由,所有出站流量均依赖ISP骨干路由进行转发。当然,在必要的时候我们可能需要做一些诸如NAT之类的配置。

!
interface GigabitEthernet0/0
 description **==CONNECTED TO ISP==**
 ip address 211.168.1.254 255.255.255.252
 duplex auto
 speed auto
 media-type rj45
!
ip route 0.0.0.0 0.0.0.0 211.168.1.253
!
ip nat inside source list 10 interface GigabitEthernet0/0
overload
!
access-list 10 permit 10.143.8.0 0.0.0.255
!

然而,在传统设计模式下,无论网络状态发生什么变化,静态配置的默认路由将一直存在于本地客户端路由器上面。换句话说,当网络当中的潜在失效节点(Potential Failure Points)出现问题的时候,ISP有可能已经无法路由从远程客户端发送过来的数据。然而本地客户端路由器却不会察觉到,而会一直依赖静态配置的默认路由向其上游节点(ISP)发送出站数据。另外一方面,也增加了客户在判断传输失效的原因是在本地还是在ISP方面的难度。
juniper-junos-aggregate-generate-dynamic-default-route-solution
而针对传统设计上的瑕疵,我们换位思考,利用JUNOS的Generate Route让ISP边缘路由器向客户动态的注入默认路由,而并非在本地客户端上配置,这使得Generate Route相对于传统在客户端静态设置缺省路由的优势显现出来。

整个设计实验当中,我们一共演示了三条自动切换的从R4Cisco IOS路由器到达Juniper JUNOS路由器R2环回接口10.0.6.2/32网段的主备链路。首先,我们需要完成包括JUNOS与IOS间的IPv4以及RIP互操作在内的底层连通性的预配置。

Juniper实验视频: Aggregate/Generate动态默认路由接入设计01

点击上文↑链接至YouTube收看高清版本实验视频

Juniper实验视频: Aggregate/Generate动态默认路由接入设计02

点击上文↑链接至YouTube收看高清版本实验视频

YouTube Juniper实验视频Link 1 主链路: R4->R3->R2

由Generate产生的默认路由通过RIP被注入到客户端路由器上,由于Generate Route依赖Contributing Routes而存在,一旦ISP边界路由器的上游节点出现故障,使得Generate Route底下没有支持它存在的Contributing Routes,ISP边缘路由器上的Generate Route将无法被激活而停留在Hidden状态。此时,默认路由将从客户端路由器消失,一方面,客户端路由器可以选择其它默认路由保证数据传输;另外一方面,客户也很容易了解到故障出现在上游ISP端。另外,我们还可以在JUNOS的策略下面设置仅当某个网段作为Contributing Route存在于ISP边界路由表中的时候,Generate Route才会向客户端路由器发送默认路由。

Juniper实验视频: Aggregate/Generate动态默认路由接入设计03

点击上文↑链接至YouTube收看高清版本实验视频

Juniper实验视频: Aggregate/Generate动态默认路由接入设计04

点击上文↑链接至YouTube收看高清版本实验视频

YouTube Juniper实验视频Link 2 第一备份链路: R4->R3->R1->R2

在这里我们主要比较的是Generate与Aggregate之间的差异。首先,我们已经了解到两者安装下一跳信息的差别,Aggregate是Reject,换句话说,假如本地路由器上没有除Aggregate路由以外的其他路由与目标网段匹配,那么该数据包将被直接丢弃。而在Generate路由中,由于Generate本身下一跳继承Contributing Routes当中数目字最小的网段路由的下一跳,即便仅有Generate路由能够与目标网段匹配,数据包仍然会被发送到与Primary Contributing Route同属一个汇总网段的下一跳上面。

Juniper实验视频: Aggregate/Generate动态默认路由接入设计05

点击上文↑链接至YouTube收看高清版本实验视频

Juniper实验视频: Aggregate/Generate动态默认路由接入设计06

点击上文↑链接至YouTube收看高清版本实验视频

YouTube Juniper实验视频Link 3 第二备份链路: R4->R2

一旦这些Contributing Route不复存在,客户端路由器上的从ISP边界路由器接收到的默认路由将自动消失。客户端路由器将自动切换到备份链路上,使用一条浮动默认路由继续发送数据。虽然,作为备份方案的常见考虑便是主链路失效到备份链路的切换。而本案的重点并不在于简单的链路备份上,而是通过Generate与RIP的巧妙结合,由远程路由的状态控制本地路由器是否通过RIP向客户端注入默认路由。因此我们仅仅通过过滤Contributing Routes来实现测试效果,而并不需要关闭相关的接口。另外我们需要在IOS路由器Customer上新增一条浮动路由用于备份传输。最后我们也完成整套设计方案的测试。

Juniper实验视频: Aggregate/Generate动态默认路由接入设计07

点击上文↑链接至YouTube收看高清版本实验视频

Labs: 配置Juniper静态路由Qualified Next-Hop

juniper-static-route-qualified-next-hop
我在今天的实验中演示了如何在Juniper路由器上配置JUNOS静态路由,设置静态路由目标IP网段,设置下一跳,JUNOS静态路由的配置选项,以及利用Qualified Next-Hop特性,为JUNOS静态路由指定独立的优先级。从而实现相对于Cisco IOS配置单条浮动路由这种单一备份链路而言,JUNOS更为优越的多条静态路由之间多链路相互备份设计方案。

Juniper实验视频: JUNOS静态路由Qualified Next-Hop配置01

点击上文↑链接至YouTube收看高清版本实验视频

Juniper实验视频: JUNOS静态路由Qualified Next-Hop配置02

点击上文↑链接至YouTube收看高清版本实验视频

Juniper实验视频: JUNOS静态路由Qualified Next-Hop配置03

点击上文↑链接至YouTube收看高清版本实验视频

实验参考文档: