Juniper实验: JUNOS IS-IS路由协议单区域配置

configuring-a-single-area-is-is-routing-in-juniper-junos
将网络策略设计与性能优化等因素暂时放到一边,而单纯考虑IS-IS在Juniper路由器上的运行的最简化配置。实际上,在实现的过程中并不会比OSPF复杂。关键的三个步骤在之前的JUNOS IS-IS路由协议配置命令举例中已经提及,包括:

  1. 在环回接口上设置NET地址;
  2. 在所有运行IS-IS路由协议的接口上启用ISO地址族;
  3. 在IS-IS路由协议下通告接口并放置在相应的level中;

而至于什么OSPF的区域边界存在于路由器内部,而IS-IS的区域边界存在于链路中间等概念都是在实践以后的体会。刚开始学习的时候并不非要被这些经验所束缚。在上面的实验视频中我仅仅用三分钟左右的时间,来完成JUNOS IS-IS路由协议单区域配置的实现。为了让实验尽可能简单,我依然使用JUNOS 101拓扑中的R1和R2两台路由器进行演示,并且将它们放在相同的IS-IS区域49.0001里面。

downloads点击下载:JUNOS 101实验台网络拓扑图

因为版面的关系,我之前将JUNOS 101的实验拓扑图的尺寸作了调整。如果你感兴趣,可以在这里下载大图。

JUNOS IS-IS接口配置 – R1

[edit logical-routers]
nigel@junos# show r1 interfaces
fxp1 {
    unit 12 {
        vlan-id 12;
        family inet {
            address 10.0.4.5/30;
        }
        family iso;
    }
}
lo0 {
    unit 1 {
        family inet {
            address 10.0.6.1/32;
        }
        family iso {
            address 49.0001.1111.1111.1111.00;
        }
    }
}

JUNOS IS-IS接口配置 – R2

[edit logical-routers]
nigel@junos# show r2 interfaces
fxp2 {
    unit 12 {
        vlan-id 12;
        family inet {
            address 10.0.4.6/30;
        }
        family iso;
    }
}
lo0 {
    unit 2 {
        family inet {
            address 10.0.6.2/32;
        }
        family iso {
            address 49.0001.2222.2222.2222.00;
        }
    }
}

JUNOS IS-IS路由协议配置 – R1

[edit logical-routers]
nigel@junos# show r1 protocols
isis {
    interface fxp1.12 {
        level 2 disable;
    }
    interface lo0.1 {
        passive;
    }
}

JUNOS IS-IS路由协议配置 – R2

[edit logical-routers]
nigel@junos# show r2 protocols
isis {
    interface fxp2.12 {
        level 2 disable;
    }
    interface lo0.2 {
        passive;
    }
}

JUNOS IS-IS路由协议单区域配置测试

第一步:查看Juniper路由器IS-IS通告接口运行状态:

nigel@junos# run show isis interface logical-router r2
IS-IS interface database:
Interface L CirID Level 1 DR  Level 2 DR  L1/L2 Metric
fxp2.12   1   0x2 junos.02    Disabled         10/10
lo0.2     0   0x1 Passive     Passive           0/0

第二步:查看Juniper路由器IS-IS邻接/邻居关系建立状态:

nigel@junos# run show isis adjacency logical-router r2
Interface System         L State Hold (secs) SNPA
fxp2.12   1111.1111.1111 1 Up            20  0:0:0:0:0:0

第三步:查看Juniper路由器IS-IS路由信息:

nigel@junos# run show isis route logical-router r2
 IS-IS routing table       Current version: L1: 3 L2: 3
IPv4/IPv6 Routes
----------------
Prefix      L Ver. Metric Type Interface Via
10.0.6.1/32 1    3     10 int  fxp2.12   1111.1111.1111

第四步:查看Juniper路由器路由表IS-IS路由协议信息:

nigel@junos# run show route logical-router r2 protocol
isis 

inet.0: 8 destinations, 8 routes (8 active,
0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

10.0.6.1/32        *[IS-IS/15] 00:23:38, metric 10
                    > to 10.0.4.5 via fxp2.12

iso.0: 1 destinations, 1 routes (1 active, 0 holddown,
0 hidden)

第五步:基于IS-IS路由协议信息的双向连通性测试:

nigel@junos# run ping 10.0.6.1 logical-router r2
source 10.0.6.2 rapid
PING 10.0.6.1 (10.0.6.1): 56 data bytes
!!!!!
--- 10.0.6.1 ping statistics ---
5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max/stddev = 0.402/0.442/0.507/0.047ms
Advertisements

One thought on “Juniper实验: JUNOS IS-IS路由协议单区域配置

  1. JUNOS IS-IS链路状态数据库LSP TLVs类型描述 Part1 « JUNIPER JUNOS & CISCO IOS 互联路由

发表评论

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / 更改 )

Twitter picture

You are commenting using your Twitter account. Log Out / 更改 )

Facebook photo

You are commenting using your Facebook account. Log Out / 更改 )

Google+ photo

You are commenting using your Google+ account. Log Out / 更改 )

Connecting to %s