JUNOS 101实验台配置及Juniper/Cisco互操作测试

junos_101_lab_network_topology

My apologies for the delay.

在之前per-packet load balancing以及前两天的GRE Tunnel两个实验中,我们采用的便是上面这个实验台。如果你正在家里练习,可以按照下面的配置逐步建立你的JUNOS 101实验台,以及JUNOS与IOS互操作的实验环境。我将这个实验台设立的步骤分成三个部分,包括:

  1. JUNOS逻辑路由器配置
  2. JUNOS逻辑路由器与Cisco IOS路由器互联配置
  3. Juniper JUNOS与Cisco IOS单区域OSPF互操作配置

马上开始 ──

1. JUNOS逻辑路由器(Logical Routers)配置

对于JUNOS的逻辑路由器功能,我只能说:“JUNOS实在太伟大了!”

尽管它并非就为了让你能够在两台Olive上便能够设置整个JNCIE实验室环境,然而逻辑路由器(LR)与虚拟路由器(VR)技术的产生确实大幅度降低了学习JUNOS实验环境的所需要的硬件门槛。使得之前不少苦于没有实验环境的JUNOS的狂热爱好者,近年也逐步加入到Juniper认证行列之中。至于如何JUNOS的逻辑路由器技术的介绍,网上已经有很多的介绍,你可以Google一下,或者到Juniper网站上了解Logical Routers更详尽的信息。我这里仅列出在配置的时候需要注意的事项。

第一:在开始配置逻辑路由器之前,确保在[edit interfaces]层次下,为你将要分配给逻辑路由器使用的接口启用了vlan-tagging,采用dot1Q封装。

第二:fxp0接口只能被用作OoB管理Telnet登录接口,unit 0fxp0接口上唯一允许被配置的逻辑单元。因此,我们一般不会使用fxp0接口来实现逻辑路由器之间的互联,而是使用另外的fxp1/fxp2/fxp3接口。

第三:在配置两台逻辑路由器间互联的时候,除了要保证两端使用相同vlan-id以外,注意要将不同的物理接口分配给逻辑路由器使用。如将fxp1.12分配给R1,那么你应该将fxp2.12分配给R2使用。如此类推,假如你需要将第三台路由器接入,与R1/R2共享一个多路访问网段的话,那么你应该将fxp3.12分配给第三台路由器使用。在我们的案例中暂时没有同一个VLAN当中需要同时接入三台路由器的情形出现。

以下为相关配置,注意在我个人的实验台上,由于实验设备存在于一个庞大的实验网络内,因此我需要在全部的VLAN-ID前都添加上了1,以便与实验网内其他Rack设备上的VLAN区分开来,而你在自己单独的实验环境下配置的时候只需要根据上面拓扑图所标识的VLAN号配置就可以了。

JUNOS Logical Routers 全局接口配置

[edit]
nigel@itaa7.2# show interfaces
/* Network MGMT Interface - DON'T Modify Configuration */
fxp0 {
    unit 0 {
        family inet {
            address 172.16.200.254/24;
        }
    }
}
fxp1 {
    vlan-tagging;
}
fxp2 {
    vlan-tagging;
}

JUNOS Logical Routers R1/R2/R3配置

[edit]
nigel@itaa7.2# edit logical-routers 

[edit logical-routers]
nigel@itaa7.2# show r1 interfaces
fxp1 {
    unit 12 {
        vlan-id 112;
        family inet {
            address 10.0.4.5/30;
        }
    }
    unit 13 {
        vlan-id 113;
        family inet {
            address 10.0.4.14/30;
        }
    }
}
lo0 {
    unit 1 {
        family inet {
            address 10.0.6.1/32;
        }
    }
}

[edit logical-routers]
nigel@itaa7.2# show r2 interfaces
fxp2 {
    unit 12 {
        vlan-id 112;
        family inet {
            address 10.0.4.6/30;
        }
    }
    unit 23 {
        vlan-id 123;
        family inet {
            address 10.0.4.2/30;
        }
    }
    unit 24 {
        vlan-id 124;
        family inet {
            address 10.0.4.10/30;
        }
    }
}
lo0 {
    unit 2 {
        family inet {
            address 10.0.6.2/32;
        }
    }
}

[edit logical-routers]
nigel@itaa7.2# show r3 interfaces
fxp1 {
    unit 23 {
        vlan-id 123;
        family inet {
            address 10.0.4.1/30;
        }
    }
    unit 34 {
        vlan-id 134;
        family inet {
            address 10.0.2.5/30;
        }
    }
}
fxp2 {
    unit 13 {
        vlan-id 113;
        family inet {
            address 10.0.4.13/30;
        }
    }
}
lo0 {
    unit 3 {
        family inet {
            address 10.0.3.3/32;
        }
    }
}

完成第一阶段配置以后,可以通过ping通对端逻辑路由器接口,以确认实现逻辑路由器间连通,例如使用logical-router R1来向与其直连的另一台逻辑路由器R2发送ICMP数据包。注意,当你配置好逻辑路由起以后,以后所有的run测试都应该在最后追加上logical-router参数

nigel@itaa7.2# run ping 10.0.4.6 logical-router r1 rapid
PING 10.0.4.6 (10.0.4.6): 56 data bytes
!!!!!
--- 10.0.4.6 ping statistics ---
5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max/stddev = 0.393/0.427/0.486/0.035 ms

2. JUNOS逻辑路由器与Cisco IOS路由器互联配置

r4#show running-config
!
hostname r4
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.24
 encapsulation dot1Q 124
 ip address 10.0.4.9 255.255.255.252
!
interface FastEthernet0/0.34
 encapsulation dot1Q 134
 ip address 10.0.2.6 255.255.255.252
!

R4#ping 10.0.4.10

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.4.10, timeout is 2
seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max
= 8/16/28 ms

3. Juniper JUNOS与Cisco IOS单区域OSPF互操作配置

这里需要注意的是在JUNOS与IOS互联的时候,由于Olive的百兆fxp接口默认MTU为1496 bytes,与IOS上快速以太网接口默认的1500 bytes不匹配,在建立OSPF邻居的时候会停留在Exchange/ExStart的状态。因此我们需要在IOS路由器上将与JUNOS相连的接口MUT值修改为与其匹配的1496 bytes。另外,你也可以发现JUNOS与IOS在不同的地方设置OSPF的router-id

JUNOS单区域OSPF配置 – R1/R2/R3

[edit logical-routers]
nigel@itaa7.2# show r1
protocols {
    ospf {
        area 0.0.0.0 {
            interface lo0.1 {
                passive;
            }
            interface fxp1.13;
            interface fxp1.12;
        }
    }
}
routing-options {
    router-id 10.0.6.1;
}

[edit logical-routers]
nigel@itaa7.2# show r2
protocols {
    ospf {
        area 0.0.0.0 {
            interface lo0.2 {
                passive;
            }
            interface fxp2.12;
            interface fxp2.23;
            interface fxp2.24;
        }
    }
}
routing-options {
    router-id 10.0.6.2;
}

[edit logical-routers]
nigel@itaa7.2# show r3
protocols {
    ospf {
        area 0.0.0.0 {
            interface lo0.3 {
                passive;
            }
            interface fxp2.13;
            interface fxp1.23;
            interface fxp1.34;
        }
    }
}
routing-options {
    router-id 10.0.3.3;
}

IOS单区域OSPF配置 – R4

r4#wr t
Building configuration...

Current configuration : 1927 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r4
!
interface Loopback0
 ip address 10.0.3.4 255.255.255.255
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.24
 encapsulation dot1Q 124
 ip address 10.0.4.9 255.255.255.252
 ip mtu 1496
!
interface FastEthernet0/0.34
 encapsulation dot1Q 134
 ip address 10.0.2.6 255.255.255.252
 ip mtu 1496
!
router ospf 64
 router-id 10.0.3.4
 log-adjacency-changes
 network 10.0.2.4 0.0.0.3 area 0
 network 10.0.3.4 0.0.0.0 area 0
 network 10.0.4.8 0.0.0.3 area 0
!

10 thoughts on “JUNOS 101实验台配置及Juniper/Cisco互操作测试

  1. 如何使用iJunOS进行Juniper/Cisco互操作练习 « 互联自由之路

  2. JUNOS Qualified Next-Hop静态路由 « JUNIPER JUNOS & CISCO IOS 互联路由

  3. Juniper/Cisco互操作: 配置JUNOS/IOS Telnet互访 « JUNIPER JUNOS & CISCO IOS 互联路由

  4. JUNOS逻辑路由器(Logical Routers)互联网接入 « JUNIPER JUNOS & CISCO IOS 互联路由

  5. Labs: 配置JUNOS逻辑路由器(Logical Routers) « JUNIPER JUNOS & CISCO IOS 互联路由

  6. Juniper实验: JUNOS IS-IS路由协议单区域配置 « JUNIPER JUNOS & CISCO IOS 互联路由

发表评论

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / 更改 )

Twitter picture

You are commenting using your Twitter account. Log Out / 更改 )

Facebook photo

You are commenting using your Facebook account. Log Out / 更改 )

Google+ photo

You are commenting using your Google+ account. Log Out / 更改 )

Connecting to %s